pdadmin-forum

pdadmin-forum » PD-Admin » Installation » [erledigt] 404 Not Found nach reboot » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen 404 Not Found nach reboot
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo, ich mal wieder.

Ich musste unseren Server am Sonntag neustarten und habe dann heute gemerkt, dass der Aufruf von *IP*/administrator mit der Fehlermeldung "404 Not Found" beantwortet wird.
*IP*/phpMyAdmin zeigte mir anfangs ein "403 Forbidden". Daraufhin in der httpd.conf geguckt und Documentroot geändert. Nun erhalte ich nur den Quellcode von phpMyAdmin an, aber nicht die Programmoberfläche. Könnte das noch ein fehlendes Recht sein oder ist PHP nicht aktiviert?

Mir gehen nun die Ideen aus, hat hier jemand evtl. einen Ansatz für mich? Die httpd.conf sieht meines Wissens nach gut aus.


Besten Dank für Eure Bemühungen!
20.03.2017 12:13 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.329

RE: 404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich denke PHP läuft nicht.
20.03.2017 16:25 Eisenherz ist online E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

Themenstarter Thema begonnen von ascTim
RE: 404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Die Websites, die auf dem Server laufen, funktionieren ohne Probleme. Ich wollte es über das GUI prüfen, aber wie oben gesagt bekomme ich einen Status-Code 404 beim Aufruf von *IP*/administrator.
20.03.2017 17:06 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
Daniel Bradler
PD-Admin Dev

Dabei seit: 11.09.2004
Beiträge: 2.376

RE: 404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Was genau haben Sie geändert und welche Meldungen finden sich im Fehler-Logfile des Webservers?
20.03.2017 18:02 Daniel Bradler ist offline Beiträge von Daniel Bradler suchen Nehme Daniel Bradler in Deine Freundesliste auf
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

Themenstarter Thema begonnen von ascTim
RE: 404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich habe den Server (virtuelle Maschine, Debian) neu gestartet.

In der error_log finde ich folgendes Eintrag:

[Tue Mar 21 10:06:17 2017] [error] [client 10.1.xxx.xxx] File does not exist: /usr/local/pd-admin2/htdocs/administrator
[Tue Mar 21 10:06:18 2017] [error] [client 10.1.xxx.xxx] File does not exist: /usr/local/pd-admin2/htdocs/favicon.ico
[Tue Mar 21 10:06:18 2017] [error] [client 10.1.xxx.xxx] File does not exist: /usr/local/pd-admin2/htdocs/favicon.ico

Dass pd-admin nicht unter /usr/local/pd-admin2/htdocs/ installiert ist ist ja soweit ich weiß der Normalfall. Unter /opt/pdadmin/www/ liegt die eigentliche Installation.

Kann es sein, dass ich eine Regel brauche, die beim Aufruf von /administrator in ein anderes DocumentRoot weiterleitet? In das /opt/pdadmin/www?
21.03.2017 10:09 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

Themenstarter Thema begonnen von ascTim
RE: 404 Not Found nach reboot Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich konnte es nun lösen, in der httpd.conf war nur eine externe IP eingetragen, keine Interne.
Nun komme ich auf die phpMyAdmin Oberfläche zwar drauf, aber erhalte beim Login in pd-admin die Meldung "Zuviele Domains.Type: free". Der Befehl ./get_license.sh über SSH hat keine Veränderung gebracht.

Über die phpMyAdmin-Tabelle "domains" konnte ich feststellen, dass 11 Domains eingetragen sind.
Eine Domain kann theoretisch gelöscht werden, wenn das der Grund sein sollte. Bloß wie mache ich das ohne pd-admin GUI?

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von ascTim: 21.03.2017 15:25.

21.03.2017 15:20 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
tbc233
Moderator


Dabei seit: 23.09.2005
Beiträge: 610
Herkunft: Linz, Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ein klein bisschen klingt das ja danach dass sich die IP Deines Servers mal geändert hat.

Am besten Du schreibst einfach mal an info@pd-admin.de und lässt Deine Lizenz checken. Nachdem das geklärt ist fürhst Du wieder das get_licence Skript aus.

__________________
Beste Grüße,
Michael
21.03.2017 15:43 tbc233 ist offline E-Mail an tbc233 senden Beiträge von tbc233 suchen Nehme tbc233 in Deine Freundesliste auf
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

Themenstarter Thema begonnen von ascTim
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ok mach ich, aber ich wüsste trotzdem kurz, ob es möglich ist die Domain auch ohne das pd-admin GUI zu löschen. :-)
21.03.2017 16:09 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
tbc233
Moderator


Dabei seit: 23.09.2005
Beiträge: 610
Herkunft: Linz, Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich würde das gar nicht versuchen. Löschen einer Domain betrifft mehrere Tabellen, Qmail Config Files und wenn es die einzige Domain eines Users ist, betrifft es auch Systemuser/gruppen, Datenbanken etc.
Laufst also eher Gefahr dann inkonsistent zu werden.

__________________
Beste Grüße,
Michael
22.03.2017 08:05 tbc233 ist offline E-Mail an tbc233 senden Beiträge von tbc233 suchen Nehme tbc233 in Deine Freundesliste auf
ascTim
Mitglied


Dabei seit: 26.08.2015
Beiträge: 15

Themenstarter Thema begonnen von ascTim
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ok danke, dann warte ich jetzt mal die Antwort für die Lizenz ab.
22.03.2017 09:49 ascTim ist offline E-Mail an ascTim senden Beiträge von ascTim suchen Nehme ascTim in Deine Freundesliste auf
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Installation » [erledigt] 404 Not Found nach reboot

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de