pdadmin-forum

pdadmin-forum » PD-Admin » Installation » [erledigt] OpenSuSE LEAP 42.1 neu Installation - Problem mit daemontools » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen OpenSuSE LEAP 42.1 neu Installation - Problem mit daemontools
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
jprusch
Mitglied


Dabei seit: 09.06.2008
Beiträge: 60

OpenSuSE LEAP 42.1 neu Installation - Problem mit daemontools Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.

- Welche Version von pd-admin wird eingesetzt? 4.27
- Welche Version der Serverumgebung wird eingesetzt? 0.272
- Welche Fehlermeldung erhalten Sie? supervise not running - file not found
- Wie sind die problematischen Dienste konfiguriert? Nach Installations Suse-skript liefert nicht das gewünschte Ergebnis
- Welche Logfile-Einträge (zB. Webserver- oder Mail-Logfile) gibt es?

Das openSUSE Skript für die Version 13.1 liefert ab Version 13.2 nicht mehr das gewünschte Ergebnis.

Die Daemontools laufen nicht. ("supervise")

Gruß,
Philipp

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von jprusch: 26.07.2016 18:33.

20.07.2016 16:43 jprusch ist offline E-Mail an jprusch senden Beiträge von jprusch suchen Nehme jprusch in Deine Freundesliste auf
jprusch
Mitglied


Dabei seit: 09.06.2008
Beiträge: 60

Themenstarter Thema begonnen von jprusch
RE: OpenSuSE LEAP 42.1 neue Installation - Problem mit daemontools Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich habe mir die Lösung erarbeitet:
Zunächst benötigt man eine funktionsfähige Version der deamontools für openSuSE LEAP 42.1.
Dieses Repository hier funktioniert:
http://download.opensuse.org/repositorie...SUSE_Leap_42.1/
(dies enthält die Version daemontools-0.76-2.1.x86_64.rpm)

Anschliessend wird das openSuSE "Nachinstallations-Skript" von Herrn Bradler modifiziert:
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
#!/bin/bash

test -e /usr/lib/systemd/system/daemontools.service && {

cat <<__ > /usr/lib/systemd/system/daemontools.service
[Unit]
Description=DJB daemontools
After=syslog.target network.target

[Service]
ExecStart=/command/svscanboot
Restart=always

[Install]
WantedBy=multi-user.target
__
ln -s /usr/lib/systemd/system/daemontools.service /etc/systemd/system/multi-user.target.wants

}

Sprich: der Pfad ist bei openSuSE ab 13.2 anders: es ist jetzt /usr/lib/systemd ....

Wenn man danach den Service "daemontools" auf "enabled" setzt, funktioniert nach dem Reboot alles wie von PD-Admin und der SE erwartet und das auf meiner gewohnten Lieblings-Distribution.

Have fun!

- Philipp

Dieser Beitrag wurde 4 mal editiert, zum letzten Mal von jprusch: 16.08.2016 20:51.

26.07.2016 18:34 jprusch ist offline E-Mail an jprusch senden Beiträge von jprusch suchen Nehme jprusch in Deine Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Installation » [erledigt] OpenSuSE LEAP 42.1 neu Installation - Problem mit daemontools

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de