pdadmin-forum

pdadmin-forum » PD-Admin » Bug-Report » Probleme bei Umstellung von PHP nach Update auf pd-admin 4.27 » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Probleme bei Umstellung von PHP nach Update auf pd-admin 4.27
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Probleme bei Umstellung von PHP nach Update auf pd-admin 4.27 Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

- Welche Version von pd-admin wird eingesetzt? 4.27
- Welche Version der Serverumgebung wird eingesetzt? 3/4-0.269

Ein Kunde wollte das ich die PHP-Version ändere auf 5.6.21, das war aber nicht möglich und endete immer mit der Fehlermeldung

code:
1:
Gateway Time-out  The gateway did not receive a timely response from the upstream server or application.


und in der Log mit der folgenden Meldung

code:
1:
Script timed out before returning headers: customer.cgi, referer: http://server.domain.de/customer/sid/82aa4857d0064ffd8bcf2531835c818efd7ff8621ef591ef/customer.cgi?todo=preferences.php5.print


Ich habe dann die PHP-Version versucht auf andere Versionen zu ändern, aber immer die gleiche Fehlermeldung. Danach habe ich dann die Version mal auf PHP 7.0.5 geändert, das hat ohne Probleme funktioniert. Danach konnte ich dann auch auf jede andere PHP-Version ändern. Diese Verhalten ist mir auf 3 Servern aufgefallen.

Ab und an kam bei der Umstellung oder danach auch folgende Meldung in der error-Log

code:
1:
 CGI::param called in list context from /opt/pdadmin/www/customer/customer.cgi line 5657, this can lead to vulnerabilities. See the warning in "Fetching the value or values of a single named parameter" at PERL2EXE_STORAGE/CGI.pm line 405., referer: http://server.domain.de/customer/sid/82aa4857d0064ffd8bcf2531835c818efd7ff8621ef591ef/navigation.cgi?lang=de&color_scheme=&user=$$user


Auf anderen Servern klappt alles ohne Probleme obwohl alle Server die gleiche pd-admin bzw. SE-Version haben.

Ist da noch jemanden etwas aufgefallen?
27.05.2016 22:46 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo

konnte das gleiche auch nachvollziehen!

__________________
Beste Grüße,
Patrick
28.05.2016 14:08 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Themenstarter Thema begonnen von Eisenherz
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich war ja schon sehr verwundert über das Problem, aber wenn es bei Dir auch auftritt, dann ist da wahrscheinlich wirklich irgendein Bug in der Programmierung der Einstellung drin.
28.05.2016 19:54 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich hab da einen Nachtrag:

bei einem "alten" Server stand heute morgen auch eine Kundenseite. Die PHP Version war auf "5.6.13" eingestellt.

Serverversion ist: 3-0.260 und pd-Admin Version ist 4.25

Eine Änderung weg von PHP 5.6 war erfolgreich und die Seite ist wieder offline.

Selber Fehler wie im Initial-Eintrag von Eisenherz.

__________________
Beste Grüße,
Patrick
30.05.2016 10:49 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Themenstarter Thema begonnen von Eisenherz
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Scheint also nicht nur mit den neusten Version von pd-admin und SE zu passieren.
Kann ich leider nicht testen, da ich alle Server auf neustem Stand habe und es mir vorher noch nicht aufgefallen ist.
30.05.2016 16:55 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Bug-Report » Probleme bei Umstellung von PHP nach Update auf pd-admin 4.27

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de