pdadmin-forum

pdadmin-forum » Allgemeines » Off-Topic/Smalltalk » SSL mit Let's Encrypt » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (6): « erste ... « vorherige 3 4 [5] 6 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen SSL mit Let's Encrypt
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
tbc233
Moderator


Dabei seit: 23.09.2005
Beiträge: 608
Herkunft: Linz, Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Zitat:
Original von Sumeragi
Eher im SEO Bereich "verpflichtend", da Google dies in sein Ranking mit einbezieht.


OT: Die Stimmen mehren sich dass das nicht zutrifft. Konnte bisher auch bei keinem einzigen Projekt eine Rankingverbesserung nach Einführung SSL feststellen und hab bisher auch von niemandem persönlich gehört dass so etwas beobachtet wurde.

__________________
Beste Grüße,
Michael
01.02.2017 08:56 tbc233 ist offline E-Mail an tbc233 senden Beiträge von tbc233 suchen Nehme tbc233 in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 626
Herkunft: Küps

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Naja sagen wir mal so.

Ich habe schon gelesen das eine der nächsten Chrome Versionen bei Webseiten mit Kontaktformular usw eine Warnung (Pishing) ausgeben soll wenn die Seite nicht https verschlüsselt ist.

Ab Version 56 ....

https://www.heise.de/newsticker/meldung/...en-3317393.html

Das mit den SEO ist ein kleiner Punkt und kann bei gewissen Seiten "unwichtig" sein und nur zusammen mit anderen sich auswirken.
01.02.2017 15:48 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
Stefan3411
Mitglied


Dabei seit: 03.10.2010
Beiträge: 74

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Könnte vielleicht nochmal jemand eine genaue Schritt für Schritt Erklärung schreiben? Insbesondere für die Installation von certbot, das erstellen von Zertifikaten und das erneuern per cronjob?

Danke!
08.02.2017 11:06 Stefan3411 ist offline E-Mail an Stefan3411 senden Beiträge von Stefan3411 suchen Nehme Stefan3411 in Deine Freundesliste auf
Tealc
Mitglied


Dabei seit: 14.09.2009
Beiträge: 148

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

das wäre für mich auch mal Interessant vorallem da ich jetzt einen neuen Server habe mit Debian 8.7, alles schon soweit läuft, nur noch nicht Let's Encrypt.

__________________
MfG

Tealc
08.02.2017 16:27 Tealc ist offline E-Mail an Tealc senden Beiträge von Tealc suchen Nehme Tealc in Deine Freundesliste auf
Daniel Bradler
PD-Admin Dev

Dabei seit: 11.09.2004
Beiträge: 2.368

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Software installieren:

code:
1:
2:
3:
4:
5:
6:
wget -O /opt/pdadmin/bin/certbot-auto https://dl.eff.org/certbot-auto
chmod 750 /opt/pdadmin/bin/certbot-auto
/opt/pdadmin/bin/certbot-auto
wget -O /opt/pdadmin/bin/letsencrypt http://download.pd-admin.de/letsencrypt
chmod 750 /opt/pdadmin/bin/letsencrypt
/opt/pdadmin/bin/certbot-auto --all


Crontab ergänzen:

code:
1:
2:
15   1    * * * /opt/pdadmin/bin/letsencrypt --all
05   3    * * 2 /opt/pdadmin/bin/certbot-auto renew
08.02.2017 16:38 Daniel Bradler ist offline Beiträge von Daniel Bradler suchen Nehme Daniel Bradler in Deine Freundesliste auf
neodg
Mitglied


Dabei seit: 10.11.2008
Beiträge: 188
Herkunft: Wald4tel/Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Diese Fehlermeldungen kommen:

/opt/pdadmin/bin/certbot-auto

Creating virtual environment...
Installing Python packages...
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Failed to find apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.

/opt/pdadmin/bin/certbot-auto --all
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Failed to find apache2ctl in PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.
23.02.2017 10:42 neodg ist offline E-Mail an neodg senden Homepage von neodg Beiträge von neodg suchen Nehme neodg in Deine Freundesliste auf
Daniel Bradler
PD-Admin Dev

Dabei seit: 11.09.2004
Beiträge: 2.368

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Es ist "/opt/pdadmin/bin/letsencrypt --all", nicht " /opt/pdadmin/bin/certbot-auto --all".
24.02.2017 11:10 Daniel Bradler ist offline Beiträge von Daniel Bradler suchen Nehme Daniel Bradler in Deine Freundesliste auf
neodg
Mitglied


Dabei seit: 10.11.2008
Beiträge: 188
Herkunft: Wald4tel/Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

So, ich habe einen neuen Server aufgesetzt (CentOS), pd-admin 6 installiert, letsencrypt installiert und SSL Zertifikate erstellen lassen.

Diese sind auch im Webinterface sichtbar und in /opt/pdadmin/sslcerts nach /etc/letsencrypt/live/ verlinkt. Das passt alles, aber beim Aufruf einer Domain mit https:/ kommt:

Fehler: Gesicherte Verbindung fehlgeschlagen
SSL_ERROR_RX_RECORD_TOO_LONG

In der error.log steht gar nichts und in der access.log steht:

- 111.111.111.111 - - [04/Mar/2017:09:19:28 +0100] "\x16\x03\x01" 400 226 "-" "-"

=> Verbesserungsvorschläge:
=> SSL Zertifikat für den Host selbst erstellen lassen inkl. phpmyadmin, pd-admin, Webmail, TLS, FTPs etc inkl. Weiterleitung auf https
=> SSL Zertifikate sollte auch ohne www erstellt werden oder gleich Weiterleitungen auf Domain mit www

Dieser Beitrag wurde 3 mal editiert, zum letzten Mal von neodg: 04.03.2017 09:26.

04.03.2017 09:21 neodg ist offline E-Mail an neodg senden Homepage von neodg Beiträge von neodg suchen Nehme neodg in Deine Freundesliste auf
neodg
Mitglied


Dabei seit: 10.11.2008
Beiträge: 188
Herkunft: Wald4tel/Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Kurze Antwort auf meine eigene Frage:

Wer ein letsencrypt Zertifikat für den pd-admin Host selbst verwenden möchte macht nach der Installation von letsencrypt ein:

code:
1:
 /opt/pdadmin/bin/letsencrypt pd-admin-hostname


danach das Script herunterladen

für Dovecot: http://download.pd-admin.de/dc-ssl-install.sh und ausführen, danach ist das pd-admin Webinterface, FTP und Mail auch verschlüsselt erreichbar.

Meiner bescheidenen Meinung nach sollte das ASAP Standard werden!
04.03.2017 09:37 neodg ist offline E-Mail an neodg senden Homepage von neodg Beiträge von neodg suchen Nehme neodg in Deine Freundesliste auf
neodg
Mitglied


Dabei seit: 10.11.2008
Beiträge: 188
Herkunft: Wald4tel/Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Nach dem Ausführen von http://download.pd-admin.de/dc-ssl-install.sh ist bei mir auch der Zertifikatsfehler weg.
04.03.2017 09:53 neodg ist offline E-Mail an neodg senden Homepage von neodg Beiträge von neodg suchen Nehme neodg in Deine Freundesliste auf
Seiten (6): « erste ... « vorherige 3 4 [5] 6 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » Allgemeines » Off-Topic/Smalltalk » SSL mit Let's Encrypt

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de