pdadmin-forum

pdadmin-forum » Allgemeines » Off-Topic/Smalltalk » Upgrade Debian 7 auf 8 » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (3): « vorherige 1 [2] 3 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Upgrade Debian 7 auf 8
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
WebTeufel
Mitglied


Dabei seit: 19.01.2012
Beiträge: 423

Themenstarter Thema begonnen von WebTeufel
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

das problem ist das die backups nicht laufen
hat sich da was an tar in der neuen version von debian geändert?
01.05.2015 23:00 WebTeufel ist offline E-Mail an WebTeufel senden Homepage von WebTeufel Beiträge von WebTeufel suchen Nehme WebTeufel in Deine Freundesliste auf Füge WebTeufel in Deine Kontaktliste ein
WebTeufel
Mitglied


Dabei seit: 19.01.2012
Beiträge: 423

Themenstarter Thema begonnen von WebTeufel
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

ich habe jetzt mal --preserve-order aus der zeile entfernt
mal sehen was die backups diese nacht machen
08.05.2015 19:59 WebTeufel ist offline E-Mail an WebTeufel senden Homepage von WebTeufel Beiträge von WebTeufel suchen Nehme WebTeufel in Deine Freundesliste auf Füge WebTeufel in Deine Kontaktliste ein
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Es läuft auf Fehler, habe ich schon probiert.
Kannst ja selber einfach mal per Hand das Script starten.
08.05.2015 22:10 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
WebTeufel
Mitglied


Dabei seit: 19.01.2012
Beiträge: 423

Themenstarter Thema begonnen von WebTeufel
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

hast recht muss man nicht die nacht abwarten Augenzwinkern
habe es ausgehührt und .... tada, ohne Probleme

nice -n 19 setuidgid $USER tar --preserve-permissions $PARM_EXCLUDE -czf $BACKUPDIR/user/$USER/$ROTATION/backup.tar.gz $HOME

frage nur ob das entfernen von --preserve-order ein großes problem darstellt
die entwickler haben es ja bisher nicht umsonst mit rein genommen

noch ein problem gelöst, also laufen die jetzt auf debian 8 nach dem upgrade
jetzt muss man mal neue install ausprobieren, jemand sagte ja schon das es nicht geklappt hat
09.05.2015 00:27 WebTeufel ist offline E-Mail an WebTeufel senden Homepage von WebTeufel Beiträge von WebTeufel suchen Nehme WebTeufel in Deine Freundesliste auf Füge WebTeufel in Deine Kontaktliste ein
WebTeufel
Mitglied


Dabei seit: 19.01.2012
Beiträge: 423

Themenstarter Thema begonnen von WebTeufel
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

auch die über nacht, alles gut gelaufen ohne fehlermeldungen
09.05.2015 12:47 WebTeufel ist offline E-Mail an WebTeufel senden Homepage von WebTeufel Beiträge von WebTeufel suchen Nehme WebTeufel in Deine Freundesliste auf Füge WebTeufel in Deine Kontaktliste ein
19Marc82
Mitglied


Dabei seit: 26.07.2013
Beiträge: 189
Herkunft: Dortmund

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hi,

ich habe zwei Server mit pd-admin. Auf beiden läuft Ubuntu 14.04.2. Bei dem einen bekomme ich gar keine eMail, obwohl der Cron da ist ist und die Mail-Adresse stimmt.
Auf dem anderen bekomme ich auch diese Meldung bei der täglichen eMail.

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
-- Warning: Skipping the data of table mysql.event. Specify the --events option explicitly.
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
Backup: dosysXxX
================
tar: Option --same-order kann nicht mit -c benutzt werden „tar --help“ oder „tar --usage“ gibt weitere Informationen.


Ich kann es mir nicht erklären. Wo kann ich noch prüfen, warum der eine Server nachts gar keine Mail sendet, aber die Backups ordentlich erstellt?

EDIT:
Sorry, falscher Beitrag... Kann das bitte jemand nach Backupscript --same-order option cannot be used with -c verschieben? Danke!

__________________
- Marc Müller -
Müller und Werkmann GbR

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von 19Marc82: 04.06.2015 10:34.

04.06.2015 10:31 19Marc82 ist offline E-Mail an 19Marc82 senden Homepage von 19Marc82 Beiträge von 19Marc82 suchen Nehme 19Marc82 in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

In /var/log/syslog kannst Du sehen, wann der Cron-Job startet.
Schaue dann in /var/log/mail.log um die Zeit, wann der Cron startet, dann siehst Du, ob da eine eMail geschrieben wird.
04.06.2015 18:35 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
19Marc82
Mitglied


Dabei seit: 26.07.2013
Beiträge: 189
Herkunft: Dortmund

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Eine Mail wurde nicht versendet, aber der Cron startet immer und das Backup ist auch da.

__________________
- Marc Müller -
Müller und Werkmann GbR
04.06.2015 21:04 19Marc82 ist offline E-Mail an 19Marc82 senden Homepage von 19Marc82 Beiträge von 19Marc82 suchen Nehme 19Marc82 in Deine Freundesliste auf
19Marc82
Mitglied


Dabei seit: 26.07.2013
Beiträge: 189
Herkunft: Dortmund

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo noch mal...
Ich habe das Problem immer noch. Die Information von oben war falsch. Es wird lediglich der Ordner des Kunden im Backupordner angelegt. In diesem sind aber keine Backups enthalten.

Wenn ich das Skript /opt/pdadmin/bin/backup.pl ausführe, kommt hier enenfalls die Meldung:
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
root@s1:~# /opt/pdadmin/bin/backup.pl
-- Warning: Skipping the data of table mysql.event. Specify the --events option explicitly.
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
tar: Entferne führende „/“ von Elementnamen
Backup: fammxxxx
================
tar: Option --same-order kann nicht mit -c benutzt werden
„tar --help“ oder „tar --usage“ gibt weitere Informationen.
Backup: firexxxx
================
tar: Option --same-order kann nicht mit -c benutzt werden
„tar --help“ oder „tar --usage“ gibt weitere Informationen.
Backup: myinxxxx
================
..........


Edit:
Ich mutze allerdings Ubuntu! Daher wird das hier nicht so ganz passen denke ich.

__________________
- Marc Müller -
Müller und Werkmann GbR

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von 19Marc82: 19.06.2015 10:56.

19.06.2015 10:55 19Marc82 ist offline E-Mail an 19Marc82 senden Homepage von 19Marc82 Beiträge von 19Marc82 suchen Nehme 19Marc82 in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ich denke mal man müsste mal die Optionen testen mit denen es unter Debian 8 und dem neuen Ubuntu funktioniert. Da Ubuntu auf Debian basiert, denke ich mal, was unter Debian funktioniert, wird auch unter Ubuntu klappen.
19.06.2015 12:54 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
Seiten (3): « vorherige 1 [2] 3 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » Allgemeines » Off-Topic/Smalltalk » Upgrade Debian 7 auf 8

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de