pdadmin-forum

pdadmin-forum » Information » Add-On Diskussionen » Problem mit dem Addon Uptime (PDA Admin-Bereich) » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Problem mit dem Addon Uptime (PDA Admin-Bereich)
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Stefan341
Mitglied


Dabei seit: 03.05.2009
Beiträge: 22

Problem mit dem Addon Uptime (PDA Admin-Bereich) Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,
ich habe mit dem Addon folgende Probleme:

1. Ich kann die Dateiberechtigungen der Datei /opt/pdadmin/www/administrator/addon_uptime.cgi nicht auf -rwsr-xr-x setzen sondern nur auf -rwsr-sr-x.
Ich denke aber mal das liegt daran, dass ich auch nicht weiß mit welchem Befehl ich das hinbekomme. Also chmod ist mir klar. Aber danach hab ich im Internet nur was mit + für Rechte hinzufügen und - für Rechte entziehen und so herausbekommen.


2. Obwohl ich sonst alles so hinbekommen habe, sehe ich im PDA kein Menüpunkt Addons und somit auch kein Uptime Untermenü. Muss ich das Menü noch irgendwo einstellen wie ich es zb bei den Resellern und den Endkunden verändern kann?
30.12.2013 20:26 Stefan341 ist offline E-Mail an Stefan341 senden Beiträge von Stefan341 suchen Nehme Stefan341 in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

RE: Problem mit dem Addon Uptime (PDA Admin-Bereich) Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Die Rechte sollten sich mit

code:
1:
chmod 4755 addon_uptime.cgi


setzen lassen.
31.12.2013 04:00 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
Stefan341
Mitglied


Dabei seit: 03.05.2009
Beiträge: 22

Themenstarter Thema begonnen von Stefan341
RE: Problem mit dem Addon Uptime (PDA Admin-Bereich) Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Zitat:
Original von Eisenherz
Die Rechte sollten sich mit

code:
1:
chmod 4755 addon_uptime.cgi


setzen lassen.


Danke das hat geklappt. Damit ich nicht das nächste Mal wieder vor so einem Problem stehe: Woher weißt du die numerische Eingabe?



Die zweite Frage ist noch offen: Im Menü sehe ich den Link nicht.
01.01.2014 23:07 Stefan341 ist offline E-Mail an Stefan341 senden Beiträge von Stefan341 suchen Nehme Stefan341 in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.368

RE: Problem mit dem Addon Uptime (PDA Admin-Bereich) Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Das kannst Du einfach ausrechnen, indem Du dir merkst:

Ausführen = 1
Schreiben = 2
Lesen = 4

Hier findest Du auch eine gute Erklärung zu chmod.

Das mit dem Addon müsste ich auch testen.
01.01.2014 23:50 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
miko93
Moderator


images/avatars/avatar-2.gif

Dabei seit: 08.09.2004
Beiträge: 1.011
Herkunft: Regensburg, Germany

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo Stefan341,

habe die Sache gerade einmal nachvollzogen. Die administrator_menu_individual.conf scheint nicht mehr angezogen zu werden. Nehme an, das wurde deaktiviert, als Einträge für Reseller und Kunden in der GUI zugänglich gemacht wurden.
Ich habe nun direkt in der /opt/pdadmin/etc/administrator_menu.conf folgendes hinzugefügt, und nun funktioniert es (Beweisfoto in der Anlage Augen rollen ):

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
 610 => {
                     name     => { de => 'AddOns',
                                   en => 'AddOns'
                                 },
                     sublinks => {100 => {
                                        name => { de => 'Uptime',
                                                  en => 'Uptime'
                                                },

                                        url  => 'addon_uptime.cgi'
                                      },
                                 200 => {
                                        name => { de => 'Bla[de]',
                                                  en => 'Bla[en]'
                                                },
                                        url  => ''
                                      },

                                 }
                     },


Schönen Gruss
MiKo

Dateianhang:
png UptimeCheck.png (165 KB, 83 mal heruntergeladen)


__________________
Frage beantwortet? Problem gelöst? Dann markiert euren Beitrag bitte als [erledigt].
04.01.2014 17:21 miko93 ist offline E-Mail an miko93 senden Homepage von miko93 Beiträge von miko93 suchen Nehme miko93 in Deine Freundesliste auf
Stefan341
Mitglied


Dabei seit: 03.05.2009
Beiträge: 22

Themenstarter Thema begonnen von Stefan341
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Super, läuft. Danke smile
05.01.2014 22:55 Stefan341 ist offline E-Mail an Stefan341 senden Beiträge von Stefan341 suchen Nehme Stefan341 in Deine Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » Information » Add-On Diskussionen » Problem mit dem Addon Uptime (PDA Admin-Bereich)

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de