pdadmin-forum

pdadmin-forum » PD-Admin » Anwendung » SSL-Zert mal wieder » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (3): [1] 2 3 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen SSL-Zert mal wieder
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Fragezeichen SSL-Zert mal wieder Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

- Welche Version von pd-admin wird eingesetzt? 4.16
- Welche Version der Serverumgebung wird eingesetzt? 0.199

Folgende Konfiguration:

Domain | IPv4 | IPv6
xyz.secbit.eu | 123.4.56.78 | 2001:0db8:85a3:08d3:...

Dies ist die Hauptdomain des pd-admin Servers!

Außerdem liegt die Domain secbit.eu ebenfalls als "Kundendomain", am gleichen System.
Es wird auch die secbit.eu für andere Server mit anderer IP genutz.

Domain | IPv4 | IPv6
xy2.secbit.eu | 123.4.56.77 | 2001:0db8:85a3:08d3:...
xy3.secbit.eu | 123.4.56.79 | 2001:0db8:85a3:08d3:...
xy001.secbit.eu | weitere subdomains für div. sachen

Ich möchte jetzt für diese Domain ein WildCard SSL-Zert bestellen und dies aufsetzen, damit:

- die PD-Admin Seiten wie Webmail, pdadmin, ... geschützt sind
- die Subdomains der Kundendomain geschützt sind
- die Subdomains, die auf anderen Server eine eigene IP besitzen, geschützt sind

--- kurz gesagt - ich möchte die WildCard voll ausnutzen..! ---

Wie gehe ich hier am besten vor? :S

LG Patrick

__________________
Beste Grüße,
Patrick
29.08.2012 09:22 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Themenstarter Thema begonnen von riedlit
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

So,

ich habe jetzt ein SSL-Zert - WildCard - und dieses Manuell in dem Standard vhost-Eintrag in der http.conf-template eingetragen...

ich habe unter erlaubte TLD auch einen Eintrag: secbit.eu
so kann ich nun für ein bestimmtest produkt dem kunden eine subdomain kunde1.secbit.eu zur verfügung stellen, wie auch schon oben beschrieben.

wenn ich aber jetzt https://kunde1.secbit.eu aufrufen will, komme ich nicht, wie mit http:// zur kundenseite sondern zur "It Works" seite vom Webserver

Welchen fehler habe ich hier?

der vhost für den Kunden wurde ebenfalls manuell eingetragen!

Danke,
Patrick

__________________
Beste Grüße,
Patrick
24.09.2012 18:23 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Themenstarter Thema begonnen von riedlit
RE: SSL-Zert mal wieder Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

OK - ich glaub ich bin echt zu blöd..

sobald ich SSL aktiviere, und die Seiten mit SSL Aufrufen will, wird als Document Root nicht das genommen, was im VirtualHost steht, sondern immer der pd-admin Standard Document Ordner mit dem "It Works!"

kennt ihr diesen Fehler?

Hier die Config:
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
<VirtualHost $$STANDARD_IP:443>
  # Bitte passen Sie in der naechsten Zeilie den Servernamen an
  ServerName $$SERVERNAME
  DocumentRoot /usr/local/pd-admin2/htdocs
  AddHandler cgi-script .cgi .pl
  RewriteEngine On
  SSLEngine on
  SSLCertificateFile /root/ssl/secbit.eu.crt
  SSLCertificateKeyFile /root/ssl/secbit.eu.key
  SSLCACertificateFile /root/ssl/intermediate.crt
  Alias /html /opt/pdadmin/www/html
  Alias /js /opt/pdadmin/www/js
  Alias /css /opt/pdadmin/www/css
  Alias /images /opt/pdadmin/www/images
  Alias /customer /opt/pdadmin/www/customer
  Alias /administrator /opt/pdadmin/www/administrator
  Alias /pop3 /opt/pdadmin/www/pop3
  RewriteRule  /customer/sid/[a-z0-9]+/(.*) /opt/pdadmin/www/customer/$1
  RewriteRule  /administrator/sid/[a-z0-9]+/(.*) /opt/pdadmin/www/administrator/$1
  RewriteRule  /pop3/sid/[a-z0-9]+/(.*) /opt/pdadmin/www/pop3/$1
  SetEnv RLIMIT_CPU 24
  SetEnv RLIMIT_NPROC 64
  SetEnv RLIMIT_AS 33554432
  SetEnv RLIMIT_AS 104857600
  SetEnv RLIMIT_NOFILE 200
  # WEBMAILER / phpMyAdmin
  ScriptAlias /cgi-sys/ /usr/local/pd-admin2/cgi-sys/
  AddHandler php5wrap .php .php3 .php4
  Action php5wrap /cgi-sys/php5-cgiwrap//usr/local/pd-admin2/htdocs/
</VirtualHost>

<VirtualHost $$STANDARD_IP:443>
  ServerName "www.space01.secbit.eui"
  DocumentRoot "/home/spacesci/www.space02.secbit.eu"
  ServerAlias space02.secbit.eu
  ServerAlias www.space02.secbit.eu.vs01.secbit.eu
  ServerAlias space02.secbit.eu.vs01.secbit.eu
  ServerAdmin p.riedl@secbit.at
  SetEnv QMAILUSER postmaster
  SetEnv QMAILHOST space02.secbit.eu
  SetEnv RLIMIT_CPU 12
  SetEnv RLIMIT_NPROC 32
  SetEnv RLIMIT_AS 64000000
  SetEnv RLIMIT_NOFILE 100
  ScriptAlias /cgi-sys/ /usr/local/pd-admin2/cgi-sys/
  AddHandler phpwrap .php3 .php4
  Action phpwrap /cgi-sys/php-cgiwrap/home/spacesci/www.space02.secbit.eu/
  AddHandler php5wrap .php .php5 .phtml
  Action php5wrap /cgi-sys/php5-cgiwrap/home/spacesci/www.space02.secbit.eu/
  SetEnv PHPRC /home/spacesci
  AddHandler cgiwrap .pl .cgi
  Action cgiwrap /cgi-sys/cgiwrap/home/spacesci/www.space02.secbit.eu/
</VirtualHost>


__________________
Beste Grüße,
Patrick
24.09.2012 20:45 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
webby
Mitglied


Dabei seit: 27.11.2009
Beiträge: 357

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

wenn ich nicht falsch liege hier die mögliche ursache:

Du hast hier zweimal stehen

code:
1:
<VirtualHost $$STANDARD_IP:443>


der apache bindet jedoch das zertifikat nur einmal an eine ip-adresse an.
Der Erste vHost bleibt erhalten. Der zweite ist ungültig.
25.09.2012 10:36 webby ist offline E-Mail an webby senden Beiträge von webby suchen Nehme webby in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Themenstarter Thema begonnen von riedlit
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ja das ist schon klar,

deshalb ist es ja eigentlich Richtig, pro vHost eine eigene IP zu Verwenden - es sollte jedoch mit dem workaround so funktionieren mit einem wildcard zert:


http://wiki.apache.org/httpd/NameBasedSSLVHosts

__________________
Beste Grüße,
Patrick
25.09.2012 10:39 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
webby
Mitglied


Dabei seit: 27.11.2009
Beiträge: 357

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Tippfehler hier? - Zeile 33
code:
1:
 ServerName "www.space01.secbit.eui"


Wenn ich das richtig sehe, muss

ServerName $$SERVERNAME (zeile 3)
und
ServerName "www.space01.secbit.eui" (zeile 33)

in der selben Domain wie auch das SSL-Zertifikat liegen.
Wenn Dein Server also heisst "mein.server.de" funktionierts nicht.

Kannst ja mal in httpd.conf schauen was hier von pdAdmin generiert wird.
25.09.2012 10:48 webby ist offline E-Mail an webby senden Beiträge von webby suchen Nehme webby in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Themenstarter Thema begonnen von riedlit
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hi - ja den habe ich schon korrigiert..

ok - meine adressconfig:


server: vs01.secbit.eu
pdadmin: vs01.secbit.eu/administrator

secbit.eu ist auch als gültige TLD in der Serverkonfiguration eingetragen, dass ich eigene Kunden wie folgt in pdadmin mit eigenem Angebot erzeugen kann:

secbit.eu

--> kunde01.sebcit.eu kann als kunde angelegt werden

diese sollen dann die subdomain und ssl erhalten.

ebenso wie die vs01.secbit.eu


lg

ps: PN

__________________
Beste Grüße,
Patrick
25.09.2012 10:57 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
webby
Mitglied


Dabei seit: 27.11.2009
Beiträge: 357

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

pn is beantwortet.

Post doch einfach mal deine configs hier rein.

Vielleicht fällt einem ja was auf...

mal noch eine andere frage: Bist du sicher das das was in der anleitung steht auch tatsächlich funktioniert? Die nennen das dort "ScratchPad" imo ist das ganze so noch nicht verifiziert...
25.09.2012 11:45 webby ist offline E-Mail an webby senden Beiträge von webby suchen Nehme webby in Deine Freundesliste auf
riedlit
Mitglied


images/avatars/avatar-31.jpg

Dabei seit: 13.09.2011
Beiträge: 371

Themenstarter Thema begonnen von riedlit
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

So - ich werde das auch als How To noch hier posten - jedenfalls: man sollte bei sowas mal drüber schlafen, die Konfig raus hauen, und neu Eintragen..

jedenfalls - ich denke es klappt (soweit ich es mit 2 subdomains probiert habe und alle leute damit wahnsinnig gemacht habe.. Augen rollen )

Danke webby für die Unterstützung!

LG

__________________
Beste Grüße,
Patrick
25.09.2012 15:01 riedlit ist offline E-Mail an riedlit senden Homepage von riedlit Beiträge von riedlit suchen Nehme riedlit in Deine Freundesliste auf
webby
Mitglied


Dabei seit: 27.11.2009
Beiträge: 357

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hey freut mich das es nun hingehauen hat smile
bestimmt irgendwo nur ein tippfehler gewesen Augenzwinkern

bin mal auf das howto gespannt smile
25.09.2012 21:13 webby ist offline E-Mail an webby senden Beiträge von webby suchen Nehme webby in Deine Freundesliste auf
Seiten (3): [1] 2 3 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Anwendung » SSL-Zert mal wieder

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de