pdadmin-forum

pdadmin-forum » Information » FAQ » PEAR Pakete für PHP5 installieren » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen PEAR Pakete für PHP5 installieren
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
noxray
Mitglied


Dabei seit: 19.12.2005
Beiträge: 177

PEAR Pakete für PHP5 installieren Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

hier steht es leider falsch -> PEAR Pakete für PHP5 installieren

richtig für php5

/usr/local/pd-admin2/php5/bin/pear install ...
11.08.2010 14:18 noxray ist offline E-Mail an noxray senden Beiträge von noxray suchen Nehme noxray in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.794
Herkunft: Berlin

RE: PEAR Pakete für PHP5 installieren Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

Zitat:
Original von noxray
hier steht es leider falsch -> PEAR Pakete für PHP5 installieren

was soll daran falsch sein?!

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
15.08.2010 00:39 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
noxray
Mitglied


Dabei seit: 19.12.2005
Beiträge: 177

Themenstarter Thema begonnen von noxray
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Es lassen sich zB Pakete welche eine neue Installer Version benötigen nicht installieren.... wurde zusammen mit Herrn Bradler geklärt. Teste mal upgrade auf pear 1.9.x ... bei list steht es dann korrekt, -v zeigt aber alte pear Version an..
15.08.2010 14:03 noxray ist offline E-Mail an noxray senden Beiträge von noxray suchen Nehme noxray in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.794
Herkunft: Berlin

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

ich habe pear 1.9.1 installiert. welche Pakete benötigen einen neuen Installer? ich konnte bisher kein Problem feststellen.
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
s2:~# /usr/local/pd-admin2/bin/pear list
Failed loading /usr/local/Zend/ZendOptimizer.so:  /usr/local/Zend/ZendOptimizer.so: undefined symbol: zend_opcode_handlers
Installed packages, channel pear.php.net:
=========================================
Package              Version State
Archive_Tar          1.3.7   stable
Console_Getopt       1.2.3   stable
HTML_Template_IT     1.3.0   stable
Mail_Mime            1.8.0   stable
Net_UserAgent_Detect 2.5.2   stable
PEAR                 1.9.1   stable
Structures_Graph     1.0.3   stable
XML_Util             1.2.1   stable
s2:~# PHP_PEAR_PHP_BIN="/usr/local/pd-admin2/bin/php5" /usr/local/pd-admin2/bin/pear list
Installed packages, channel pear.php.net:
=========================================
Package              Version  State
Archive_Tar          1.3.7    stable
Archive_Zip          0.1.1    beta
Auth                 1.6.2    stable
Auth_SASL            1.0.4    stable
Cache_Lite           1.7.8    stable
Console_Color        1.0.2    stable
Console_Getopt       1.2.3    stable
DB                   1.7.13   stable
DB_DataObject        1.9.5    stable
DB_NestedSet         1.4.1    stable
Date                 1.4.7    stable
File                 1.3.0    stable
File_Archive         1.5.4    stable
File_Find            1.3.0    stable
File_Gettext         0.4.1    beta
File_HtAccess        1.2.1    stable
File_Passwd          1.1.7    stable
HTML_BBCodeParser    1.2.2    stable
HTML_CSS             1.5.4    stable
HTML_Common          1.2.5    stable
HTML_Common2         2.0.0RC1 beta
HTML_Menu            2.1.4    stable
HTML_TreeMenu        1.2.1    stable
HTTP                 1.4.1    stable
HTTP_Download        1.1.3    stable
HTTP_Header          1.2.0    stable
HTTP_Request         1.4.4    stable
HTTP_Upload          0.9.1    stable
HTTP_WebDAV_Server   1.0.0RC4 beta
I18Nv2               0.11.4   beta
Log                  1.12.1   stable
MDB                  1.3.0    stable
MDB2                 2.4.1    stable
MDB2_Driver_mysql    1.4.1    stable
MDB2_Driver_mysqli   1.4.1    stable
MDB2_Driver_pgsql    1.4.1    stable
MDB2_Driver_sqlite   1.4.1    stable
MDB_QueryTool        1.2.2    stable
MIME_Type            1.2.0    stable
Mail                 1.2.0    stable
Mail_Mime            1.8.0    stable
Mail_mimeDecode      1.5.1    stable
Net_FTP              1.3.7    stable
Net_IMAP             1.1.0    stable
Net_POP3             1.3.7    stable
Net_Ping             2.4.5    stable
Net_SMTP             1.4.2    stable
Net_Sieve            1.3.0    stable
Net_Socket           1.0.9    stable
Net_URL              1.0.15   stable
Net_UserAgent_Detect 2.5.2    stable
PEAR                 1.9.1    stable
PHPUnit              1.3.2    stable
Pager                2.4.8    stable
Structures_Graph     1.0.3    stable
Text_Password        1.1.1    stable
Translation2         2.0.1    stable
VFS                  0.3.0    beta
Validate             0.8.3    beta
XML_Feed_Parser      1.0.3    stable
XML_Parser           1.3.2    stable
XML_RPC              1.5.4    stable
XML_Serializer       0.20.0   beta
XML_Util             1.2.1    stable

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
15.08.2010 15:35 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
altomom
Mitglied


Dabei seit: 13.09.2004
Beiträge: 102

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hmm, was genau heisst denn: "wurde geklärt"?

Bei mir liefert
/usr/local/pd-admin2/bin/pear list
u.a. ein
PEAR 1.5.0 stable
und
PHP_PEAR_PHP_BIN="/usr/local/pd-admin2/bin/php5" /usr/local/pd-admin2/bin/pear list
u.a. ein
PEAR 1.9.1 stable

-V beharrt darauf, dass ich Version 1.5.0 habe. Möchte ich aber z.B.
PHP_PEAR_PHP_BIN="/usr/local/pd-admin2/bin/php5" /usr/local/pd-admin2/bin/pear install MAIL
machen, dann kriege ich den freundlichen Hinweis, dass das erst mit dem PEAR Installer ab 1.5.6 geht, nicht mit meinem 1.5.0

Wie "überliste" ich ihn denn nun? Augenzwinkern
16.11.2011 15:49 altomom ist offline E-Mail an altomom senden Homepage von altomom Beiträge von altomom suchen Nehme altomom in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.794
Herkunft: Berlin

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

führe einmal folgendes aus:
code:
1:
/usr/local/pd-admin2/bin/pear upgrade-all

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
16.11.2011 16:45 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
altomom
Mitglied


Dabei seit: 13.09.2004
Beiträge: 102

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
attila:/usr/local # /usr/local/pd-admin2/bin/pear upgrade-all
Will upgrade archive_tar
Will upgrade console_getopt
Will upgrade html_template_it
Will upgrade net_useragent_detect
Will upgrade pear
pear/Archive_Tar requires PEAR Installer (version >= 1.5.4), installed version is 1.5.0
pear/Console_Getopt requires PEAR Installer (version >= 1.8.0), installed version is 1.5.0
pear/PEAR requires package "pear/Archive_Tar" (version >= 1.3.7), installed version is 1.3.2
pear/PEAR dependency package "pear/Console_Getopt" installed version 1.2.1 is not the recommended version 1.2.3, but may be compatible, use --force to install
downloading HTML_Template_IT-1.3.0.tgz ...
Starting to download HTML_Template_IT-1.3.0.tgz (23,309 bytes)
........done: 23,309 bytes
downloading Net_UserAgent_Detect-2.5.2.tgz ...
Starting to download Net_UserAgent_Detect-2.5.2.tgz (11,986 bytes)
...done: 11,986 bytes
upgrade-all ok: channel://pear.php.net/HTML_Template_IT-1.3.0
upgrade-all ok: channel://pear.php.net/Net_UserAgent_Detect-2.5.2

Soviel dazu... Augenzwinkern Hatte ich nämlich schon versucht... Augenzwinkern
16.11.2011 17:20 altomom ist offline E-Mail an altomom senden Homepage von altomom Beiträge von altomom suchen Nehme altomom in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.794
Herkunft: Berlin

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

schon "--force" versucht?

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
16.11.2011 18:07 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
altomom
Mitglied


Dabei seit: 13.09.2004
Beiträge: 102

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Yep, damit kriege ich die Meldung weg, dass PEAR auch mit der nicht gewünschten 1.2.1 von Console_Getopt (statt 1.2.3) installiert werden könnte. Doch da Archive_Tar ja wg. der Installer-Version nicht geht, klappt das PEAR Upgrade eh nicht...

Verzwickte Sache...
16.11.2011 18:42 altomom ist offline E-Mail an altomom senden Homepage von altomom Beiträge von altomom suchen Nehme altomom in Deine Freundesliste auf
Twilo
Moderator


images/avatars/avatar-5.png

Dabei seit: 12.09.2004
Beiträge: 2.794
Herkunft: Berlin

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hallo,

ich meine mich zu erinnern, dass ich damals alles per --force o.ä. upgegraded habe.

mfg
Twilo

__________________
Wunschzettel smile
Farbtabelle
16.11.2011 18:45 Twilo ist offline Homepage von Twilo Beiträge von Twilo suchen Nehme Twilo in Deine Freundesliste auf
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » Information » FAQ » PEAR Pakete für PHP5 installieren

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de