pdadmin-forum

pdadmin-forum » PD-Admin » Bug-Report » Customer Oberfläche liefert nur eine Fehlermeldung » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Customer Oberfläche liefert nur eine Fehlermeldung
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
IP-Logic
Mitglied


Dabei seit: 12.05.2008
Beiträge: 76

Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Aktuelle SE / PDA auf Debian 6 minimal

Hallo zusammen,
ich habe vorhin SE und PDA aktualisiert und kann nun die Customer Oberfläche nicht mehr aufrufen.

Die Fehlermeldung habe ich mal beigefügt und es er schimpft über die IP ????

Zur historie des Servers, er ist vor drei Wochen in ein anderes RZ gekommen und hat somit auch eine neue IP erhalten... das war ziemlich holperig und ich habe das Gefühl das es wieder um das gleiche Thema geht ...

Wäre toll wenn ihr mir helfen könntet ... ich stehe gerade echt ratlos da..

very Danke :-)

Sascha

Dateianhang:
jpeg customer.jpeg (124,42 KB, 128 mal heruntergeladen)
29.12.2017 14:01 IP-Logic ist offline E-Mail an IP-Logic senden Beiträge von IP-Logic suchen Nehme IP-Logic in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.415

RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Also ich hatte das Problem auch bei einem Kunden der Debian 6 eingesetzt hat.
Ich habe ihn dann überzeugen können auf CentOS 7 zu migrieren, da ich es für wenig sinnvoll hielt auf dem nicht mehr in Wartung stehenden Debian den Fehler zu suchen und der Fehler war damit behoben. Ich weiß, dass hilft jetzt leider nicht bei Deinem Problem, aber da man pd-admin ja relativ problemlos migrieren kann, würde ich Dir raten auf eine neue Version von Debian oder CentOS zu setzen. Da der Kunde auch Debian 6 hatte gehe ich jetzt mal davon aus, dass es vielleicht eher nicht an der IP liegt, denn der Server lief schon viele Jahre mit der gleichen IP und erst nach dem SE-Update kam der Fehler auf.
29.12.2017 14:51 Eisenherz ist online E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
IP-Logic
Mitglied


Dabei seit: 12.05.2008
Beiträge: 76

Themenstarter Thema begonnen von IP-Logic
RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

naja, ich habe einen zweiten Server in identischer Konfiguration der ohne Probleme läuft ... der "Problemserver" ist halt nur mal umgezogen und hat eine neue IP bekommen. Sporadisch hatte er immer mal Probleme mit der Namensauflösung und dann kam es zu Timeouts und komischem Verhalten....

Die letzten drei Monate nach dem Umzug ist der Server so "vor sich hingelaufen" ohne das sich aktiv jemand darauf eingeloggt hat ... der Fehler kann also auch nicht in direktem Zusammenhang mit den heutigen Updates stehen...
29.12.2017 17:30 IP-Logic ist offline E-Mail an IP-Logic senden Beiträge von IP-Logic suchen Nehme IP-Logic in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.415

RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Also ist auf dem zweiten Server auch schon die neuste SE und pd-admin-Version drauf?
29.12.2017 17:37 Eisenherz ist online E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
IP-Logic
Mitglied


Dabei seit: 12.05.2008
Beiträge: 76

Themenstarter Thema begonnen von IP-Logic
RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

ja, habe beide heute Morgen aktualisiert und nur der Server mit der damals geänderten IP macht die Probleme...

Da ich mich aber nie auf der Customer Oberfläche anmelde, kann das Problem auch schon vor dem update vorhanden gewesen sein...

(Habe es erst gemerkt als ich für einen Account ein neues Mailpostfach anlegen wollte und über VERWALTEN in den Customer Bereich springen wollte)
29.12.2017 17:46 IP-Logic ist offline E-Mail an IP-Logic senden Beiträge von IP-Logic suchen Nehme IP-Logic in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.415

RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Also bei meinem Kunden war es erst nach dem Update auf eine neue SE und es betraf auch nur den Login als /customer, wenn es auf dem anderen Server funktioniert und der gleich ist, dann ist es natürlich seltsam. Wobei es sich, soweit ich mich erinnern kann, eine Reihe 3 Installation war und das Update war das auf SE 0.299, wobei da natürlich auch schon vorher das Problem gewesen sein kann, da er sich ja vielleicht auch nicht immer per /customer einloggt hat.
30.12.2017 03:54 Eisenherz ist online E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
IP-Logic
Mitglied


Dabei seit: 12.05.2008
Beiträge: 76

Themenstarter Thema begonnen von IP-Logic
RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Vielleicht hat Herr Bradler eine Idee oder jemand liest vielleicht noch dieses Thema und kann einen Tipp beisteuern...

Vorsichtshalber werde ich wohl oder übel schon mal einen neuen Server parallel aufsetzen ... da graut mir ein wenig vor, ich habe noch nie eine Konfiguration auf einen anderen Server gehoben der eine "neue OS und PDA" bekommen hat ....

:-(

Vielleicht ist mein "Bammel" ja auch unbegründet, aber im Moment graut es mir davor auch wenn nur 8 Customer auf dem Server liegen....

liebe Grüße, Sascha
30.12.2017 11:43 IP-Logic ist offline E-Mail an IP-Logic senden Beiträge von IP-Logic suchen Nehme IP-Logic in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.415

RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Leider kann man ja nicht in die Datei schauen, sonst würde man den Fehler sicher einfacher finden. Der Fehler scheint aber ja in der Umwandlung bei der Ausführung der Datei zu liegen. Vielleicht noch ein paar Tipps zum Umzug, dann musst Du Dir eigentlich wenig sorgen machen. Ich installiere zuerst pd-admin in gleicher Reihe und SE auf dem Zielserver und stoppe es dann sofort, dann kopiere ich per rsync /home, damit schon einmal die großen Dinge drüben sind. Am Ende synce ich dann per rsync noch /opt/pdadmin, /pdadmin und /var/qmail selber. Die Dateien, die Du kontrollieren musst, findest Du alle in dieser Erklärung.

Hier habe ich Dir die Kommandos mal kopiert:

code:
1:
2:
3:
4:
5:
rsync -Parqlog /home/ root@neuerserver:/home
rsync -Parqlog /opt/pdadmin/etc/ root@neuerserver:/opt/pdadmin/etc
rsync -Parqlog /var/qmail/control/ root@neuerserver:/var/qmail/control
rsync -Parqlog /var/qmail/users/ root@neuerserver:/var/qmail/users
rsync -Parqlog /usr/local/pd-admin2/ root@neuerserver:/usr/local/pd-admin2

Noch zur kurzen Ergänzung: pd-admin ist das Linux eigentlich egal, da es ja alles selber mitbringt, nur die nötigen Pakete sollten da sein.
30.12.2017 11:48 Eisenherz ist online E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
IP-Logic
Mitglied


Dabei seit: 12.05.2008
Beiträge: 76

Themenstarter Thema begonnen von IP-Logic
RE: Customer Oberfläche liefert nur eine Fehlermeldung Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Aktueller Status :

....der neue Server ist da und und hat eine Debian 9.3 netinst ohne irgendeine Auswahl im tasksel bekommen. "Locals" alles auf Deutsch...

Dann die Basisdienste installieren mit:
apt-get install iftop ssh mc patch make psmisc zip imagemagick gcc g++ libc6-dev-i386 lib32stdc++6 lib32ncurses5 lib32z1 rrdtool groff

Dann sshd abgesichert und aus der hosts alle IP6 Einträge auskommentiert.
mit wget www.pd-admin.de/download/pdadmin_v4-md5.tar.gz PDA runtergeladen, entpackt uuuuund ... erst mal stop ;-)

Der alte Server ist ein Debian 6 mit SE 2.303 -> also Reihe 2 ??
Wenn ich den neuen mit ./install-sh starte bekommt der doch die Reihe 4 installiert?? richtig?

Ich habe mir die verlinkte "Erklärung" zum Serverumzug mal angeschaut ... scheitere aber schon an den ersten Dingen :-(

MUSS der neue Server immer die gleiche SE und Reihe haben ? es sind nur 7 Domains auf dem alten Server ... kann ich die evtl auch einzeln umziehen lassen?

Wie gehe ich am besten vor?
Schon mal Danke im Voraus und Gruß, Sascha
17.01.2018 00:44 IP-Logic ist offline E-Mail an IP-Logic senden Beiträge von IP-Logic suchen Nehme IP-Logic in Deine Freundesliste auf
tbc233
Moderator


Dabei seit: 23.09.2005
Beiträge: 658
Herkunft: Linz, Österreich

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Für den beschriebenen Umzug mit rsync etc. ist es hilfreich wenn Quelle und Ziel die idente Serverumgebung und Reihe einsetzen. Merzt Fehlerquellen aus.

Ich gehör aber zu jenen, die der Meinung sind dass das beschriebene Umzugsprocedere zwar sehr effektiv, aber definitiv nur etwas für geübte Admins ist. Es muss hier wirklich jeder Schritt passen. Wenn zum Beispiel vergessen wird, die User aus /etc/passwd/shadow VOR der Installation der SE zu übernehmen, kommt am Schluss ein furchtbares Gewurschtel aus UID/GUIDs raus, dass nur sehr umständlich wieder zu beheben ist und unangenehme Auswirkungen auf Mailverkehr, FTP Zugänge etc. hat.

Mein Eindruck ist dass du hier nicht so routiniert bist und ganz ehrlich: Wegen sieben Domains würde ich mir das an Deiner Stelle nicht antun. Mach ein Clean Install von pd-admin (dürfte ja eh schon geschehen sein), leg in aller Ruhe die Domains und die Mailboxen an und transferriere die Webinhalte.

__________________
Beste Grüße,
Michael
17.01.2018 05:25 tbc233 ist offline E-Mail an tbc233 senden Beiträge von tbc233 suchen Nehme tbc233 in Deine Freundesliste auf
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Bug-Report » Customer Oberfläche liefert nur eine Fehlermeldung

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de