pdadmin-forum

pdadmin-forum » PD-Admin » Anwendung » Pagespeed aktivieren » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Seiten (2): [1] 2 nächste » Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Pagespeed aktivieren
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Pagespeed aktivieren Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Muss man pagespeed eigentlich in der Conf Template aktivieren oder geht das auch per htaccess?

Habe es gerade per htaccess probiert aber ist nicht aktiv.
08.07.2016 12:58 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.440

RE: Pagespeed aktivieren Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Du kannst an oder aus in der htaccess ändern, aber das Modul muss im Apachen geladen werden.
08.07.2016 15:12 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

OK also muss ich die http-template anpassen

In die schaute ich schon ob man vielleicht nur auskommentieren muss.

Welche Zeile muss da rein?
08.07.2016 15:58 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.440

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Analog zu den anderen Modulen fügst Du "mod_pagespeed.so" ein.
08.07.2016 23:06 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Hmm auf allen Servern ist das Modul nicht ausführbar und hat nur 644 Rechte.

wenn ich es einbinde mit der Bezeichnung mod_pagespeed.so dann bekomme ich beim Neustart:

code:
1:
httpd: Syntax error on line 103 of /usr/local/pd-admin2/conf/httpd.conf: Can't locate API module structure `mod_pagespeed' in file /usr/local/pd-admin2/modules/mod_pagespeed.so: /usr/local/pd-admin2/modules/mod_pagespeed.so: undefined symbol: mod_pagespeed
09.07.2016 22:54 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
Eisenherz
Moderator


Dabei seit: 29.04.2009
Beiträge: 1.440

Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Wundert mich gerade auch, wenn man es in 755 umändert dann erscheint die gleiche Fehlermeldung.
10.07.2016 00:22 Eisenherz ist offline E-Mail an Eisenherz senden Beiträge von Eisenherz suchen Nehme Eisenherz in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Yup genau

habe gerade nochmal einen Testserver aufgesetzt um alles besser testen zu können.

Diese Meldung hat mich heute schon 8 Stunden auszeit gekostet. Da ich es gestern auf einen Server aktiviert hatte.

Scheinbar hat mich dann der Browsercache spät Nachts verarscht.

Erst heute Mittag viel mir auf das der eine Shop nimmer ging.

Langsam brauchen wir mal eine aktuelle Doku zu allen großes Grinsen großes Grinsen
10.07.2016 00:31 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Wenn ich es statt mod_pagespeed pagespeed_module nenne dann erstellt er mir schonmal die httpd.conf ohne Fehler. Aber der Apache startet dann erstmal nicht mehr.

Also weitersuchen großes Grinsen
10.07.2016 00:59 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Ok wenn man in der httpd.conf-template

dies vor den VirtualHosts einträgt nimmt er alles an und startet auch den Apachen wieder.
code:
1:
2:
3:
ModPagespeed On
ModPagespeedInheritVHostConfig on
ModPagespeedFileCachePath "/var/cache/mod_pagespeed/"

Werde nunmal testen ob er pagespeed auch wirklich nutzt:
10.07.2016 01:21 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
chrischnian
Mitglied


Dabei seit: 30.03.2005
Beiträge: 651
Herkunft: Küps

Themenstarter Thema begonnen von chrischnian
Antworten | Zitieren | Editieren | Melden       Zum Anfang der Seite springen

Das Pagespeed Module wird zwar nun geladen aber die Filter scheinen keinen Effekt zu haben.

wie ist das mit der pagespeed.conf im Ordner /usr/local/od-admin2/conf dort scheint ja alles soweit eingestellt zu sein.

Wie kann ich erreichen das diese genutzt wird? Somit sollte dann ja das Module und Filter erfolgreich laufen.
14.07.2016 09:17 chrischnian ist offline E-Mail an chrischnian senden Homepage von chrischnian Beiträge von chrischnian suchen Nehme chrischnian in Deine Freundesliste auf
Seiten (2): [1] 2 nächste » Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
pdadmin-forum » PD-Admin » Anwendung » Pagespeed aktivieren

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de