pdadmin-forum

pdadmin-forum » Suche » Suchergebnis » Hallo Gast [Anmelden|Registrieren]
Zeige Beiträge 1 bis 20 von 627 Treffern Seiten (32): [1] 2 3 nächste » ... letzte »
Autor Beitrag
Thema: End of script output before headers: administrator.cgi
chrischnian

Antworten: 2
Hits: 52
16.05.2018 14:02 Forum: Anwendung


Danke Herr Bradler

ich habe überall nachgeschaut aber an die Hosts dachte ich nicht. Danke nochmal
Thema: End of script output before headers: administrator.cgi
chrischnian

Antworten: 2
Hits: 52
End of script output before headers: administrator.cgi 16.05.2018 12:37 Forum: Anwendung


Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.

- Welche Version von pd-admin wird eingesetzt? aktuell
- Welche Version der Serverumgebung wird eingesetzt? aktuell
- Welche Fehlermeldung erhalten Sie?

code:
1:
2:
3:
4:
5:
6:
7:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.


- Wie sind die problematischen Dienste konfiguriert?
- Welche Logfile-Einträge (zB. Webserver- oder Mail-Logfile) gibt es?

Es ging auch mal das Webinterface aber wenn ich in den Admin gehen kommt nur diese Meldung

code:
1:
[Wed May 16 12:33:30.953558 2018] [cgid:error] [pid 14160] [client 87.175.137.210:49124] End of script output before headers: administrator.cgi, referer: http://109.235.60.149/administrator/sid/96eefb5a913e57af89d26fbf86ef3df745a560c423285ae9/administrator.cgi?todo=main


Habe eine ganz alte Installation geupdatet kann gar nicht sagen was da aktuell davor drauf war.
Habe davor auch von Debian 6 auf Debian 9 geupdatet

Der Superdienst ist nicht hochgefahren das konnte ich durch (keine dienste nach neustart.) lösen.
Thema: REDIS Cache nutzen
chrischnian

Antworten: 14
Hits: 592
08.05.2018 23:56 Forum: Anwendung


Wer hat es schonmal probiert über PECL - Redis zu installieren.

Wenn ich von der Webseite wie oben geschrieben die Befehle nehme bekomme ich folgenden Fehler:
code:
1:
2:
3:
4:
root@vmd16158:/usr/local/pd-admin2/bin# ./pecl install redis
pecl/redis requires PHP (version >= 5.3.0, version <= 7.9.99), installed version is 4.4.9
No valid packages found
install failed
Thema: 12 Jahre sind es nun schon...
chrischnian

Antworten: 3
Hits: 189
09.04.2018 11:22 Forum: Off-Topic/Smalltalk


Ja lang lang ist es her.

Vieles ist passiert aber auf Facebook findet man nichts über PD-Admin Augenzwinkern

Was ich auch sehr gut finde. Ein gutes "altes" Forum hat für mich mehr wie dieses schnelllebige Facebook.
Thema: Bootstrap Modal - Cookie
chrischnian

Antworten: 1
Hits: 121
22.03.2018 08:43 Forum: Off-Topic/Smalltalk


Ok nun klappt es soweit:

Man kann sich eintragen und es wird dann nichtmehr angezeigt und auch per Button wird es nichtmehr angezeigt.

Wie müsste man nun vorgehen wenn der User es nur wegdrückt (über das X) dann soll es 1 Tag nichtmehr angezeigt werden.

Hier der aktuelle Code:

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
    <div class="modal fade" id="myModal">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">Modal title</h4>
                </div>
                <div class="modal-body">
                    <p>Your Mailchimp form goes here, or whatever you like. Example input below.</p>
                    <div class="input-group">
                        <span class="input-group-addon"><span class="glyphicon glyphicon-envelope"></span></span>
                        <input type="email" class="form-control" placeholder="Email Address">
                    </div>
                </div>
                <div class="modal-footer">
                    <!-- Make sure to include the 'nothanks' class on the buttons -->
                    <button class="pull-left btn btn-default btn-xs nothanks" data-dismiss="modal" aria-hidden="true">Don't Show Me This Again</button>
                    <button class="pull-right btn btn-primary nothanks" data-dismiss="modal" aria-hidden="true">Subscribe</button>
                </div>
            </div><!-- /.modal-content -->
        </div><!-- /.modal-dialog -->
    </div><!-- /.modal -->

{literal}
    <!-- Cookie JS for Modal -->
    <script src="https://cdnjs.cloudflare.com/ajax/libs/jquery-cookie/1.4.0/jquery.cookie.min.js"></script>
    <script>
        // Delayed Modal Display + Cookie On Click
        $(document).ready(function() {

            // If no cookie with our chosen name (e.g. no_thanks)...
            if ($.cookie("no_thanks") == null) {

                // Show the modal, with delay func.
                $('#myModal').appendTo("body");
                function show_modal(){
                    $('#myModal').modal();
                }

                // Set delay func. time in milliseconds
                window.setTimeout(show_modal, 3000);
                }

            // On click of specified class (e.g. 'nothanks'), trigger cookie, with expiration in year 9999
            $(".nothanks").click(function() {
                document.cookie = "no_thanks=true; expires=Fri, 31 Dec 9999 23:59:59 UTC";

            });
        });
    </script>
{/literal}
Thema: Bootstrap Modal - Cookie
chrischnian

Antworten: 1
Hits: 121
Bootstrap Modal - Cookie 21.03.2018 15:29 Forum: Off-Topic/Smalltalk


Leute vielleicht könnt ihr mir mal helfen.

Ich habe im Internet das gefunden, geht aber noch nicht so wie ich das will. Leider ist JS nicht mein Gebiet.

Ich möchte das nach Aufruf einer Webseite nach X Sekunden das Modal kommt.
Es soll weggehen wenn man woanders hinklickt oder das Formular wegsendet.

Wenn man es nur wegklickt soll es nach 24h wieder erscheinen. Klickt man im Modal auf "Don't Show" dann soll es für immer wegbleiben.

Danke für eure Tipps
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
    <div class="modal fade" id="myModal" role="dialog">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button>
                    <h4 class="modal-title">Modal title</h4>
                </div>
                <div class="modal-body">
                    <p>Your Mailchimp form goes here, or whatever you like. Example input below.</p>
                    <div class="input-group">
                        <span class="input-group-addon"><span class="glyphicon glyphicon-envelope"></span></span>
                        <input type="email" class="form-control" placeholder="Email Address">
                    </div>
                </div>
                <div class="modal-footer">
                    <!-- Make sure to include the 'nothanks' class on the buttons -->
                    <button class="btn btn-default nothanks" data-dismiss="modal" aria-hidden="true">Don't Show Me This Again</button>
                    <button class="btn btn-primary nothanks" data-dismiss="modal" aria-hidden="true">Subscribe</button>
                </div>
            </div><!-- /.modal-content -->
        </div><!-- /.modal-dialog -->
    </div><!-- /.modal -->

{literal}
    <!-- Cookie JS for Modal -->
    <script src="https://cdn.jsdelivr.net/npm/js-cookie@2/src/js.cookie.min.js"></script>
    <script>
        // Delayed Modal Display + Cookie On Click
        $(document).ready(function() {
            // If no cookie with our chosen name (e.g. no_thanks)...
            if ($.cookie("no_thanks") == null) {
                // Show the modal, with delay func.
                function show_modal(){
                    $('#myModal').modal();
                }
                // Set delay func. time in milliseconds
                window.setTimeout(show_modal, 300);
            }
            // On click of specified class (e.g. 'nothanks'), trigger cookie, which expires in 100 years
            $(".nothanks").click(function() {
                $.cookie('no_thanks', 'true', { expires: 36500, path: '/' });
            });
        });
    </script>
{/literal}
Thema: Pagespeed aktivieren
chrischnian

Antworten: 12
Hits: 776
20.02.2018 09:44 Forum: Anwendung


Bei mir zeigt er zwar bei
code:
1:
2:
3:
$ /usr/local/pd-admin2/httpd-2.4/bin/httpd -M | grep page
pagespeed_module (shared)
$

Alles ok an.

Aber beim Link: https://ismodpagespeedworking.com/
und der Domain www.moebro.de da sagt er das er es nicht findet.
In welche Zeile sollte es in der Conf.template eingetragen werden.

EDIT: 10:33

Es geht nun es wurde der falsche Apache geladen
Thema: Pagespeed aktivieren
chrischnian

Antworten: 12
Hits: 776
19.02.2018 16:07 Forum: Anwendung


Ich will mich morgen mal wieder an das Thema machen.

Hat das jemand schon erfolgreich am laufen?

Wenn ja wie habt ihr das gemacht?
Thema: PHP Startup: apc_mmap: mmap failed:
chrischnian

Antworten: 1
Hits: 184
PHP Startup: apc_mmap: mmap failed: 28.11.2017 19:34 Forum: Anwendung


Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.

- Welche Version von pd-admin wird eingesetzt? v4.57
- Welche Version der Serverumgebung wird eingesetzt? 4.0300
- Welche Fehlermeldung erhalten Sie?

PHP Fatal error: PHP Startup: apc_mmap: mmap failed: in Unknown on line 0
Segmentation fault

- Wie sind die problematischen Dienste konfiguriert? Standard

Wenn ich den CronJob per Konsole als User ausführe geht alles ohne Probleme. Heute ist mir aber aufgefallen das beim aufrufen des CronJobs per so wie er eingetragen wurde on PD-Admin dann bekomme ich diese Meldung wie man oben sieht.
Thema: Debian 9 64Bit installation
chrischnian

Antworten: 6
Hits: 244
27.11.2017 23:28 Forum: Anwendung


Könnte gerade am Schreibtisch schreien großes Grinsen

Zammad mit Debian 8 oder 9 und PD-Admin SE 4 klappt nicht da MySQL 5.6 als minimum gebraucht wird.

Also SE 6 mit Debian 9 nun geht PD-Admin nicht und zeigt mir einen 500er an.

Also nochmal was anderes probieren.

Gerade nicht mein Tag Augenzwinkern
Thema: Debian 9 64Bit installation
chrischnian

Antworten: 6
Hits: 244
27.11.2017 20:26 Forum: Anwendung


habe aus Z=`./readlink $n`

nun Z=`readlink $n`

verändert
Thema: Debian 9 64Bit installation
chrischnian

Antworten: 6
Hits: 244
27.11.2017 20:20 Forum: Anwendung


Auch das Paket: libnet-sftp-sftpserver-perl

keine Besserung gleicher Fehler
Thema: Debian 9 64Bit installation
chrischnian

Antworten: 6
Hits: 244
27.11.2017 20:17 Forum: Anwendung


Nein das habe ich schon installiert!
Thema: Debian 9 64Bit installation
chrischnian

Antworten: 6
Hits: 244
Debian 9 64Bit installation 27.11.2017 19:17 Forum: Anwendung


Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.

- Welche Version von pd-admin wird eingesetzt? 4.57
- Welche Version der Serverumgebung wird eingesetzt? 0.300
- Welche Fehlermeldung erhalten Sie?
code:
1:
./install-all.sh: line 260: ./readlink: No such file or directory

- Wie sind die problematischen Dienste konfiguriert? noch gar nicht
- Welche Logfile-Einträge (zB. Webserver- oder Mail-Logfile) gibt es? siehe oben


Beim start der Installation unter Debian 9 kommt der oben genannte Fehler.

Die Zeile um die es geht

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
mycnfdef=${BASEDIR}/etc/my.cnf
for n in /etc/my.cnf /etc/mysql/my.cnf; do
   if [ -L $n ]; then
      Z=`./readlink $n`       <= hier die Zeile
      if [ $? -ne 0 ]; then
         FAULT=1
      fi
      if [ "$Z" != "${BASEDIR}/etc/my.cnf" ]; then
         echo "$n is a symlink but does not point to $mycnfdef"
         FAULT=1
      else
         echo "(info: $n is a symlink which points to $mycnfdef)"
      fi
   elif [ -f $n ]; then
      echo "ERROR: Please rename $n!"
      FAULT=1
   fi
done
Thema: Ruby on Rails
chrischnian

Antworten: 30
Hits: 18.869
26.11.2017 22:08 Forum: Wunschecke


Ja hast recht werde ich mal machen!
Thema: Ruby on Rails
chrischnian

Antworten: 30
Hits: 18.869
26.11.2017 15:44 Forum: Wunschecke


Ok habe mal auf einen lokalen VServer es installiert.

Es lief am Schluß über den "Hauseigenen Port 3000" ohne Probleme. war noch Englisch aber OK.

Nun nach einen Neustart läuft es nicht. Es ist so wie wenn Ruby nicht mehr da ist bzw die richtige Version.

Ich habe es so aufgesetzt. Debian 8 und 64Bit!

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
1. apt-get install g++ gcc imagemagick lib32ncurses5 lib32stdc++6 lib32z1 libc6-dev-i386 make patch psmisc rrdtool git libmysqlclient-dev mc

2. PD-Admin installieren

3. /opt/pdadmin/bin/create_reseller.pl "RESELLER X"
	LoginID: YYYY, Password: XXXX

4. Endkunden anlegen und Datenbank erstellen für Zammad

5. sudo apt-get install ruby

6. Punkt 1. von https://docs.zammad.org/en/latest/install-source.html

7. chown -R zammad.zammad /opt/zammad/

8. apt-get install rubygems build-essential

9. cd /opt/zammad

10. gem install bundler rake rails

11. cd /root/

12. Weiter unter - https://tecadmin.net/install-ruby-on-rails-on-ubuntu/#

13. cd /opt/zammad

14. gem install bundler rake rails

15. apt-get install git libmysqlclient-dev

16. bundle install --without test development postgres

17. cp config/database.yml.pkgr config/database.yml

18. database.yml anpassen

19. export RAILS_ENV=production

20. export RAILS_SERVE_STATIC_FILES=true

21. mysqld.sock verlinken

22. rake db:create

23. rake db:migrate

24. rake db:seed

25. cd /opt/zammed

26. rake assets:precompile

Ich versuche den Fehler zu finden. Vielleicht hat jemand auch interesse. Mir geht es vorallem danach das ganze über den PD-Admin Apache auszuliefern um auch LetsEncrypt und die "normalen" Ports nutzen zu können. Ich werde mal berichten.
Thema: Symlink nach neustart neu erstellen
chrischnian

Antworten: 1
Hits: 166
Symlink nach neustart neu erstellen 23.11.2017 22:55 Forum: Anwendung


Ich habe 2 Skripte die nach /var/run/mysqld/mysqld.sock linken.

Daher setze ich einen Link von der SE in das Verzeichnis

Nach einen Neustart sind diese Links immer weg.

Wie kann ich die automatisch wieder setzen lassen. Oder kann ich die zb in die my.cnf mit eintragen?
Thema: Ruby on Rails
chrischnian

Antworten: 30
Hits: 18.869
23.11.2017 08:58 Forum: Wunschecke


Wie zufrieden warst du generell mit Zammad?

OTRS ist mir zu fett und hat keinen Chat. Derzeit haben wir LiveZilla aber müssten nun mehr Lizenzen kaufen und es sind ein paar Sachen dabei die mir nicht so gut gefallen.

Ich habe es gestern mal auf einen PD-Admin Server laufen gehabt. NGINX lief und auch die Zammad Dienste.

Nur das Frontend lief noch nicht.
Thema: Ruby on Rails
chrischnian

Antworten: 30
Hits: 18.869
22.11.2017 21:59 Forum: Wunschecke


Ich möchte mal Zammad testen.

Es wird aber Ruby gewünscht, wie schwer oder leicht ist die Parallele Installation davon?
Thema: Ruby on Rails
chrischnian

Antworten: 30
Hits: 18.869
12.09.2017 10:01 Forum: Wunschecke


Wie schaut es aus?

Wer hat es schon erfolgreich am laufen?
Zeige Beiträge 1 bis 20 von 627 Treffern Seiten (32): [1] 2 3 nächste » ... letzte »

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de