pdadmin-forum

pdadmin-forum » Suche » Suchergebnis » Hallo Gast [Anmelden|Registrieren]
Zeige Beiträge 1 bis 20 von 602 Treffern Seiten (31): [1] 2 3 nächste » ... letzte »
Autor Beitrag
Thema: CronJobs Limits
chrischnian

Antworten: 5
Hits: 45
23.06.2017 09:36 Forum: Anwendung


Das hört sich super an Herr Bradler

danke
Thema: CronJobs Limits
chrischnian

Antworten: 5
Hits: 45
22.06.2017 15:43 Forum: Anwendung


yup

php.ini usw ist mehr eingestellt aber dennoch bekommen wir Fehler. Will es mal versuchen damit unsere Crons gut durchlaufen
Thema: CronJobs Limits
chrischnian

Antworten: 5
Hits: 45
CronJobs Limits 22.06.2017 15:32 Forum: Anwendung


Wenn ich mir die Crontab meiner Users anschaue dann steht davor ja

code:
1:
/usr/local/bin/softlimit -m 300000000 -o 200 -p 80 -t 180


Wie kann ich die beeinflussen?

Wir bekommen einen 500er bzw Memory Fehler beim ausführen
Thema: SSL mit Let's Encrypt
chrischnian

Antworten: 57
Hits: 4.222
18.06.2017 12:21 Forum: Off-Topic/Smalltalk


Wunderte mich auch. Aber denke mal das es, wenn es im Angebot, aktiviert ist dann für alle Domains aufgeschaltet bzw aktiviert wird.

Wie ist das mit den Subdomains? Werden die auch verschlüsselt und oder muss man die eigen hinzufügen über die Konsole.

Wie ist das bei den Subdomains mit den "www" muss ich die auch extra anlegen oder werden die von sich aus angelegt?
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
02.06.2017 10:59 Forum: Anwendung


Seit gestern Abend habe ich es am laufen. Der Fehler lag am Installationsskript.

Wenn man es über Composer installiert hat dann ruft man php ja über /usr/local/pd-admin2/bin/php-7.0-cli auf

mittendrin hat aber das Installationsskript das ganze nochmal mit "php" aufgerufen was unter /bin/ ja nicht gibt und dadurch wurde was nicht beendet.

Ich habe es nun mit PHP7 nun am laufen. Aber das auch der JTL-Shop / Piwik / Mautic die ja offiziell PHP7 ready sind es nicht erkennen. Ist mir ein Rätsel.

Aber egal ich habe es erstmal erreicht was ich wollte.
Vielleicht sollte man doch mal prüfen ob man das APCu_BC doch nicht braucht??
Aber dazu kann nur Herr Bradler was sagen.
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
01.06.2017 17:50 Forum: Anwendung


Ich habe nochmal geschaut.

Kann es sein das wir "apcu-bc" benötigen. Dies scheint eine Komponenten zu sein für die Abwärtskompatibiltät.

https://serverpilot.io/community/article...-extension.html
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
01.06.2017 15:16 Forum: Anwendung


Also wenn ich das apcu unter php 5.6 aktiviere wird es von allen Systemen erkannt.

Unter php 7.0 nicht?

Bin gerade ein wenig verwirrt.
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
01.06.2017 12:52 Forum: Anwendung


Ok aber wie kann es sein das es nicht erkannt wird?

Das ist immernoch die Frage. Die Skripte sind tw professionelle oder stark genutzt. Dennoch wird es nicht erkannt.

Ich bin kein Programmierer denke aber das diese nicht eigenentwicklungen nutzen sonder schon an vorhandenen anknüpfen!

Wo kann ich hier noch was machen?
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
30.05.2017 10:00 Forum: Anwendung


Wäre alles richtig eingerichtet von der php.ini her?

Für APCu muss doch kein Dienst eingerichtet werden wie für Memcache oder?
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
30.05.2017 09:08 Forum: Anwendung


Also es scheint doch noch ein Problem zu geben.

Wenn ich unter einen User den eine eigene php.ini hat und somit ioncube Loader und opcodecache aktiviert ist dies über die Konsole mit -v prüfen will kommt folgendes:

/usr/local/pd-admin2/bin/php-7.0-cli -v

code:
1:
2:
3:
4:
PHP 7.0.19 (cli) (built: May 16 2017 15:09:34) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.8, Copyright (c) 2002-2016, by ionCube Ltd.


Da müsste doch eigentlich opcache und ionCube kommen oder?
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
30.05.2017 08:29 Forum: Anwendung


Naja ob 3 Skripte sich täuschen können?

1. JTL-Shop
2. NextCloud
3. Mautic

Zu den Error:
code:
1:
PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0


Habe nun die erweiterungen in der php.ini am Schluß anders sortiert:
code:
1:
2:
3:
4:
5:
6:
7:
8:
extension_dir = ""
extension = apcu.so
extension = imagick.so
extension = intl.so
extension = soap.so

zend_extension = /home/ioncube/ioncube_loader_lin_7.0.so
zend_extension = opcache.so


Davor waren die beiden zend_extensions getauscht.

Nun habe ich zwar keinen 500er mehr aber dennoch wird nichts erkannt.
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
29.05.2017 14:55 Forum: Anwendung


keiner ähnliche Erfahrungen oder kann es bestätigen oder kann generell was dazu sagen.
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
26.05.2017 00:36 Forum: Anwendung


Also sobald ich den OPCACHE mit laden lassen geht nichts mehr.

Weder unter 7.0 noch unter 5.6

Der APCU wird nie erkannt somit auch wirkungslos
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
25.05.2017 23:38 Forum: Anwendung


Habe bei mir auch NextCloud laufen.

Diese empfehlen in der php.ini dies einzutragen:
code:
1:
2:
3:
4:
5:
6:
7:
opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

habe also in der php.ini
als letztes
code:
1:
2:
3:
4:
5:
6:
7:
8:
extension_dir = ""
extension = apcu.so
extension = imagick.so
extension = intl.so
extension = soap.so

zend_extension = opcache.so
zend_extension = /home/ioncube/ioncube_loader_lin_7.0.so

Nun bekomme ich nur noch 500er angezeigt.

PHP 7.0.19
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
24.05.2017 21:31 Forum: Anwendung


Ja genau

http://www.lichte-kraft.eu/phpinfo.php

Das Skript ist: http://akeneo.com/
Thema: PHP accelerator wird nicht erkannt
chrischnian

Antworten: 17
Hits: 332
PHP accelerator wird nicht erkannt 24.05.2017 17:03 Forum: Anwendung


Dies ist eine vorgefertigte Schablone, die bei der Formulierung von Problemen unterstützen soll. Bitte die folgenden Angaben möglichst vollständig ausfüllen.

- Welche Version von pd-admin wird eingesetzt? aktuell
- Welche Version der Serverumgebung wird eingesetzt? aktuell
- Welche Fehlermeldung erhalten Sie?
code:
1:
| WARNING | Install and/or enable a PHP accelerator (highly recommended).


- Wie sind die problematischen Dienste konfiguriert?
code:
1:
2:
3:
4:
5:
6:
7:
extension_dir = ""
extension = apcu.so
extension = imagick.so
extension = intl.so
extension = soap.so

zend_extension=/home/ioncube/ioncube_loader_lin_7.0.so


Ich habe unter PHP7.0 APCU aktiviert. Dies wird auch in der PHPINFO als aktiv angezeigt. Aber 2 Skripte erkenne es nicht.

Bin gerade ratlos beim OPCache kommt das gleiche, welcher ist besser bzw was muss man machen das einer davon erkannt wird?
Thema: Mod, Cgi, Fcgi, Fpm
chrischnian

Antworten: 0
Hits: 81
Mod, Cgi, Fcgi, Fpm 11.05.2017 10:30 Forum: Anwendung


Wie sind eure erfahrungen mit FPM?
Wer hat es schon am laufen?
Thema: 500er aber warum?
chrischnian

Antworten: 8
Hits: 143
28.04.2017 20:07 Forum: Anwendung


Dennoch wieder ein 500er

Error_log
code:
1:
2:
[Fri Apr 28 19:49:50 2017] [error] [client 91.9.14.198] FastCGI: comm with (dynamic) server "/opt/pdadmin/etc/phpfcgi/lichtebs/starter" aborted: (first read) idle timeout (120 sec), referer: http://produkte.lichte-kraft.eu/user/login
[Fri Apr 28 19:49:50 2017] [error] [client 91.9.14.198] FastCGI: incomplete headers (0 bytes) received from server "/opt/pdadmin/etc/phpfcgi/lichtebs/starter", referer: http://produkte.lichte-kraft.eu/user/login

Error_log von akeneo
code:
1:
2:
3:
4:
[2017-04-28 19:53:48] request.INFO: Matched route "oro_default". {"route_parameters":{"template":"PimDashboardBundle:Dashboard:index.html.twig","_controller":"Symfony\\Bundle\\FrameworkBundle\\Controller\\TemplateController::templateAction","_route":"oro_default"},"request_uri":"http://produkte.lichte-kraft.eu/"} []
[2017-04-28 19:54:39] request.CRITICAL: Uncaught PHP Exception PDOException: "SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction" at /home/lichtebs/produkte.lichte-kraft.eu/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php line 509 {"exception":"[object] (PDOException(code: HY000): SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction at /home/lichtebs/produkte.lichte-kraft.eu/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php:509)"} []
[2017-04-28 19:56:05] request.INFO: Matched route "oro_default". {"route_parameters":{"template":"PimDashboardBundle:Dashboard:index.html.twig","_controller":"Symfony\\Bundle\\FrameworkBundle\\Controller\\TemplateController::templateAction","_route":"oro_default"},"request_uri":"http://produkte.lichte-kraft.eu/"} []
[2017-04-28 19:56:56] request.CRITICAL: Uncaught PHP Exception PDOException: "SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction" at /home/lichtebs/produkte.lichte-kraft.eu/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php line 509 {"exception":"[object] (PDOException(code: HY000): SQLSTATE[HY000]: General error: 1205 Lock wait timeout exceeded; try restarting transaction at /home/lichtebs/produkte.lichte-kraft.eu/vendor/symfony/symfony/src/Symfony/Component/HttpFoundation/Session/Storage/Handler/PdoSessionHandler.php:509)"} []

Ich frage mal auch bei GITHUB aber vielleicht hatte jemand schon gleiche Fehlermeldungen?
Thema: 500er aber warum?
chrischnian

Antworten: 8
Hits: 143
28.04.2017 17:22 Forum: Anwendung


Na toll den Beitrag habe ich nicht gefunden aber danke @Eisenherz
Thema: 500er aber warum?
chrischnian

Antworten: 8
Hits: 143
28.04.2017 16:02 Forum: Anwendung


wo müsste ich das eintragen?
Zeige Beiträge 1 bis 20 von 602 Treffern Seiten (31): [1] 2 3 nächste » ... letzte »

Impressum | Team | Hilfe

Forensoftware: Burning Board, entwickelt von WoltLab GmbH    |    Design entwickelt von You-Online.de